Leave these fields empty (spam trap):
Comment
[i]Italic Text[/i]
[b]Bold Text[/b]
[spoiler]Spoiler Text[/spoiler]
>Highlight/Quote Text
[pre]Preformatted & Monospace Text[/pre]
[super]Superset Text[/super]
[sub]Subset Text[/sub]
1. Numbered lists become ordered lists
* Bulleted lists become unordered lists
File

Sandwich


420chan is Getting Overhauled - Changelog/Bug Report/Request Thread (Updated July 26)

Please fix whatever is eating my posts.

Reply
- Wed, 07 Aug 2019 22:40:36 EST 0sowEETP No.257383
File: 1565232036634.jpg -(50192B / 49.02KB, 367x367) Thumbnail displayed, click image for full size. Please fix whatever is eating my posts.
I don't know if it's cloudflare or something else but about 1/4 of the time I hit submit post and then it goes through the cloudflare screen and then nothing happens and I have to do the entire fucking thing again. I'm now having to habitually save my posts to a notepad before I hit submit, might be that is sees certain IPs as suspicious but why allow the same damn post through on a second or third attempt? Maybe some sort of flood/spam prevention. There's not even an error message for it it just drops me back to page 1 of whatever board it was and that's that.

This didn't happen even a week ago.
>>
Kirtaner !Ub4TCdRjOM - Thu, 08 Aug 2019 00:30:18 EST ZGdceZR7 No.257389 Reply
Still an issue?
>>
Isabella Decklenon - Thu, 08 Aug 2019 02:51:06 EST 4gdbGf60 No.257394 Reply
>>257383
>save my posts to a notepad
Just copy it to the clipboard bro.
Ironically my post just failed on the taima.pl page
>>
Rebecca Dottingcocke - Thu, 08 Aug 2019 06:39:28 EST 9KJFXIHB No.257399 Reply
have you tried just refreshing the page? maybe it won't work if you've been redirected to cloudflare but usually if a post drops, refreshing the error screen sends the same thing through as before and it posts
>>
Hannah Bimmlebeck - Thu, 08 Aug 2019 08:03:12 EST 4hYHgb4k No.257400 Reply
>>257383
It's not about race, politics, or religion, so it's not welcome here anymore.
>>
Eliza Billyfield - Thu, 08 Aug 2019 12:04:29 EST 0sowEETP No.257403 Reply
>>257389
Yup, literally just happened a few minutes ago.
>>257394
My clipboard has a memory of ~50 previous ones as well I'm just used to doing it the shitty way.
>>
Eliza Billyfield - Thu, 08 Aug 2019 12:07:35 EST 0sowEETP No.257404 Reply
>>257399
>have you tried just refreshing the page? maybe it won't work if you've been redirected to cloudflare but usually if a post drops, refreshing the error screen sends the same thing through as before and it posts
I don't get an error usually it just goes back to page 1 of the board. Usually though just trying 1-2 more times to post the exact same thing goes through. It is indeed that taima.pl page where it fails. It happens both with and without an image being posted so it's not that.
>>
Kirtaner !Ub4TCdRjOM - Thu, 08 Aug 2019 12:20:05 EST ISylaa9A No.257406 Reply
>>257404
I really need more details. Dev console request header screenshots, network activity, the works.
>>
Emma Singermure - Thu, 08 Aug 2019 19:44:55 EST jHz5huG8 No.257410 Reply
>>257406
It could be due to privacy related addons, perhaps the user agent spoofer? Maybe it doesn't like your browser changing from reporting edge to safari during posting.
>>
Nigel Gallymitch - Thu, 08 Aug 2019 20:01:15 EST jHz5huG8 No.257411 Reply
>>257406
>>257410
Actually I'm now suspecting it might definitely be related to certain IPs/IP ranges being detected as suspicious. My IP changed again a few hours ago and the problem hasn't occurred since.
>>
Simon Poshwack - Thu, 08 Aug 2019 21:37:08 EST 8N9Akbfq No.257414 Reply
>>257406
>>257411
Yup it's IP-related, either VPN IPs I habitually use them when on someone else's wifi as should everyone or certain mobile internet IPs where someone else has probably been recently abusing the same connection are affected but not on a 'normal' one at home. It's strange that it just chooses to eat posts at random without an error message or similar instead of outright denying the ability to post though and I can confirm it will allow an identical post to go through on a second or third attempt. Maybe it flags the underlying IP as suspicious (and fair enough) adding to a 'deny' score and then some sort of other behaviour (user agent changing, trying to post too often, cookie/javascript-related privacy addons etc) on top of it occasionally tips the score over the threshold into 'eat it'.

Cloudflare until a few months ago outright blocked all access to 420chan from IPs it didn't like so this is still an improvement on the old situation. If fixing it opens 420chan to attack/spam or whatever then no problem I'll just live with it when I'm posting away from home but it might be some sort of configuration thing you can mess with, I don't know how much is under your control and how much is just how Cloudflare functions.

>>257394
If you're still here and since you seem to have experienced it too care to confirm if you're posting from an IP cloudflare might flag as suspicious? VPN, mobile internet, perhaps even just assigned a dynamic IP by your ISP (last one particularly relevant if Dutch or Russian)? That'd at least help with isolating that as the cause.
>>
Kirtaner !Ub4TCdRjOM - Thu, 08 Aug 2019 22:08:02 EST ZGdceZR7 No.257415 Reply
>>257414
I have very granular control over firewall triggers and have been slowly disabling ones I find not relevant to our stack after researching them. There's a few hundred on by default.

I'll go check their logs for events from your IP.
>>
Simon Poshwack - Thu, 08 Aug 2019 23:13:23 EST 8N9Akbfq No.257417 Reply
>>257415
Thanks, I can confirm that specific IP (the one you're replting to) had it happen at least once as did the IP used in the OP (also me if that was unclear). Like I said it's not a big issue so if it's any risk to the site's stability I can live with it, I just travel a lot for work so I hit it often.

If it's any use for you when on the move I also use these which may cause weird events that could be interpreted as malicious:
>self-destructing cookies
15s after the tab is closed, though I've now whitelisted 420chan so this no longer happens. By the way it seems like the random name assignment is stored either purely as a cookie or a combination of cookie + IP but the ID you're assigned is based on IP only so the name will change if your cookie is deleted but the ID won't. Weird to have them behave differently but not an issue in any way.
>adblockers of various types
>tracker blocking of various types
So common I doubt they're likely to be an issue but I'll note them.
>User agent spoofer
Changes what browser, what version and what OS is reported to the site, on paper to avoid fingerprinting but in practice it probably causes more hassle than it's worth. I've also disabled this on 420chan's domain for the time being but I figure that these suddenly changing (it's automatic) might be a suspicious event.
>webRTC disabler
Self-explanatory
>greasemonkey
But not running anything with it.
>>
Simon Poshwack - Thu, 08 Aug 2019 23:15:44 EST 8N9Akbfq No.257418 Reply
>>257417
>By the way it seems like the random name assignment is stored either purely as a cookie or a combination of cookie + IP but the ID you're assigned is based on IP only so the name will change if your cookie is deleted but the ID won't. Weird to have them behave differently but not an issue in any way.
Just testing this now, same IP but cookies deleted. Let's see what happens.
>User agent spoofer
I've not had it happen since I disabled this so that might be it. I'll report if it does.
>>
Simon Poshwack - Thu, 08 Aug 2019 23:53:18 EST 8N9Akbfq No.257420 Reply
>>257419
That's it then, I'll keep the addon disabled since it's really not necessary here. Thanks for your help.

Report Post
Reason
Note
Please be descriptive with report notes,
this helps staff resolve issues quicker.